Certified Archiving temporarily not available

Incident Report for Nitrobox

Resolved

This incident has been resolved.
Posted Mar 31, 2025 - 19:22 CEST

Investigating

We are currently investigating this issue.
Posted Mar 31, 2025 - 16:05 CEST
This incident affected: Certified Document Archiving Solution.